Author Topic: 454 K10 Truck Resto  (Read 3486 times)

Offline Altec

  • Super Hero
  • ******
  • Join Date: Jul 2011
  • Posts: 2768
  • location: SoCo, MD
  • DILLIGAF
Re: 454 K10 Truck Resto
« Reply #75 on: March 13, 2017, 09:13:26 AM »
It's a SM465 three speed with low. The only other 4 speed they offered was the NP833, which is very rare in a 4wd trim, and is very light duty. The 465 is bomb proof.

And the engine is a 454 BB. th-smile the combo is decent. It pulls like a freight train.
"Play stupid games, you get stupid prizes."JJ

Offline fatfillup

  • numbnuts
  • Spins ratchet
  • *
  • Join Date: Jun 2010
  • Posts: 18114
  • location: Maryland
Re: 454 K10 Truck Resto
« Reply #76 on: March 13, 2017, 09:23:08 AM »
I can see it now,,,,,,,,,,,,,,,,,,,,,,,,,,,

"Altec's Stump Pulling Services" :))
That scalloped box end is one of the few BB features that doesn't make Elroy puke

Offline Altec

  • Super Hero
  • ******
  • Join Date: Jul 2011
  • Posts: 2768
  • location: SoCo, MD
  • DILLIGAF
Re: 454 K10 Truck Resto
« Reply #77 on: March 18, 2017, 07:23:02 PM »
So, today I was informed by the better half that she was going to clean and watch a Netflix series today and I was to stay the hell away.  lolx 

I took the truck out to get lunch and decided to find out why my blower motor wasn't working. You can start from a few places but going by previous wiring issues I've had on this truck I decided to check the fuses. It was there! So next I just wrapped on the motor. Normally a bad motor will jump start if you smack it. That wasn't it. Broke out the test light and I'm not getting power to the relay for the high setting, or power to the resistor. Next step was to unscrew the head unit, and the problem became very clear.  lolx See the picture... After feeling around under the dash I found the harness and plugged it back in and the motor came to life! Even had all speeds! Though it has a dry bearing that will randomly rawr. No big deal, I'll just have to get a replacement.

At the same time I replace the motor I will hook up my vacuum ball and run the vacuum line for the HVAC. Right now I just have floor air blowing.

On another note I have been finding the "little things" that need to be addressed. Like, I don't have cup holders!  panicx I also only have low and high on my wipers. The intermittent wiper module seems to be shot. I also am noticing the wipers are a little slow. I imagine its a power or grounding issue. I'll figure it out, but for the time it works.
"Play stupid games, you get stupid prizes."JJ

The Garage Gazette

Re: 454 K10 Truck Resto
« Reply #77 on: March 18, 2017, 07:23:02 PM »

Tags: